WLW 10.3 - Build error of unable to resolve type on weblogic.security.SimpleCallbackHandler after upgrade from 8.1 to 10.3 (Doc ID 1224163.1)

Last updated on JUNE 09, 2016

Applies to:

Oracle Workshop for Weblogic - Version 10.3 and later
Oracle Weblogic Server - Version 10.3 to 10.3.3
Information in this document applies to any platform.
***Checked for relevance on 22-Jul-2013***

Symptoms

After upgrading an application from WebLogic 8.1 to 10.3, you might get compilation or build errors when trying to build the application which indicating that the class weblogic.security.SimpleCallbackHandler is not found.

The error is either "unable to resolve type" when the application is built in WebLogic Workshop (WLW) 10.3, or ClassNotFoundException when compiled outside of WLW.

Changes

Upgrade from WLS 8.1 to 10.3

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms