On upgrading WLW project from 8.1 to WLW 10.3 the below error is noticed: "A control fields type must be annotated with @ControlInterface or @ControlExtension if its an interface". (Doc ID 1279554.1)

Last updated on DECEMBER 03, 2012

Applies to:

Oracle Workshop for Weblogic - Version: 10.3 to 10.3 - Release: AS10gR3 to AS10gR3
Information in this document applies to any platform.

Goal

On upgrading WLW project from 8.1 to WLW 10.3 the below error is noticed in workshop.
A control fields type must be annotated with @ControlInterface or @ControlExtension if its an interface. Verify the type of the control field declaration is annotated correctly. The type of the control field is malformed. Verify that the source of the type has no errors.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms