REP-56040 At Startup After Installing A Second Oracle 11g Weblogic Home (Doc ID 1290271.1)

Last updated on JULY 13, 2016

Applies to:

Oracle Reports Developer - Version 11.1.1.2.0 and later
Information in this document applies to any platform.
***Checked for relevance on 06-OCT-2014***

Symptoms

Installing a second WebLogic 11gR1 Home with Oracle Forms and Reports fails to start the standalone Reports Server.

The error resulting from startup is:

Message ID REP-56040
Message Level 1
Relationship ID 0
Component reports
Module oracle.reports.server

Host longhostname001.domain.us
Host IP Address 11.11.215.5
Thread ID 10
ECID 0000IqPuo^58hoaLpMs1yY1DDRp1000001


Message REP-56040 : Server reportsserver_longhostname001_ already exists in the network.

Supplemental Detail oracle.reports.RWException: IDL:oracle/reports/RWException:1.0
at oracle.reports.utility.Utility.newRWException(Utility.java:1046)
at oracle.reports.server.RWServer.startServer(RWServer.java:1088)
at oracle.reports.server.RWServer.jniMain(RWServer.java:305)



This domain is looking for:
<server>reportsserver_longhostname001_csss12</server>
but in truncates at 30 characters

The other domain full name is:
<server>reportsserver_longhostname001_csss11</server>

For both Domains/Oracle Homes, the directory paths and actual opmn calls are to the same truncated reportsserver_longhostname001_.

Due to this issue, cannot start second Reports Server.

Changes

Installed a second WebLogic 11gR1 Home with Oracle Forms and Reports.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms