SSO 10g Install with HA OIDs Error: Query Returned: 2 Cannot establish connection ,ldapbind failed with "NZ Error - 28862"

(Doc ID 1321446.1)

Last updated on SEPTEMBER 14, 2016

Applies to:

Oracle Application Server Single Sign-On - Version 10.1.2 to 10.1.4.3 [Release 10gR2 to 10gR3]
Information in this document applies to any platform.

Symptoms

In HA(High Availability) enviroment setup with two nodes for OID and two nodes for SSO and Load balancer between them.

1>.When trying to install SSO and while LDAP is querying, it fails with below error :

FileName
----------------
installActions<timestamp>.log



*** Specify LDAP Virtual Host and Ports Page***
Calling Query LDAPGlobalQueries1.3.3.0.2 RunLDAPQuery

queryNumber = 0

argsArr =virtualhost.abc.com,13130,,,oracle.ias.repqueries.InstallSSLSocketFactoryImpl,
Query Returned: 2,Cannot establish connection with the following input: host:virtualhost.abc.com port:13130 bindDN: bindPwd: ***** SSL Socket Factory:oracle.ias.repqueries.InstallSSLSocketFactoryImpl,
Error:*** Alert: Error validating the SSL port settings from this Oracle Internet Directory. Verify that this Oracle Internet Directory, its database and listener are running, that it is configured to support SSL and non-SSL connections, and that you have entered the correct hostname and SSL port number. ***
User Selected: Yes/OK

Warning:*** Alert: Do you really want to exit? ***
User Selected: Yes/OK

User Exit


2>.With Load balancer address and SSL port ldapbind fails with below error.And with OID physical hostname ldapbind works fine with both SSL and non-SSL ports


oracle@lmdcssoap1:/home/oracle> ldapbind -h virtualhost.abc.com -p 13130 -U 1
SSL Failure : NZ Error - 28862

Changes

.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms