My Oracle Support Banner

Which Are the Mandatory Libraries For Tuxedo MQ Adapter? (Doc ID 1326912.1)

Last updated on JANUARY 28, 2019

Applies to:

Oracle Tuxedo - Version: 11.1.1.2.0 and later   [Release: 11g and later ]
Information in this document applies to any platform.

Goal

When installing Oracle Tuxedo MQSeries Adapter which IBM WebSphere MQSeries package should be installed so we get the following required files?
/opt/mqm/lib/libmqmxa.so
/opt/mqm/lib/libmqm.so

These files are required to set up the WebSphere MQ XA Compliant Resource Manager.  Without these files, commands like:
buildTM_MQI -o $APPDIR/TM_MQI
buildTM_MQO -o $APPDIR/TM_MQO
buildTMQUEUE_MQM -v -o $APPDIR/TMQUEUE_MQM
buildtms -o $APPDIR/TMS_MQ -r MQSeries_XA_RMI

fail with the following error:
ld: Can't find dependent library "libmqm.so"
Fatal error.


Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
  Goal
  Solution

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.