My Oracle Support Banner

Issue when Microsoft Active Directory Application Mode (ADAM) Integrates with WLS Using Active Directory Authentication Security Provider (Doc ID 1342884.1)

Last updated on SEPTEMBER 03, 2019

Applies to:

Oracle WebLogic Server - Version 9.0 and later
Information in this document applies to any platform.

Symptoms

When we try to assign ADMIN/OPERATOR/MONITOR OR any global role to any Microsoft Active Directory Application Mode (ADAM) user, we get a error in the console stating that user does not exist even though the user exists in LDAP.

From the logs, for a user <username> (present in ADAM) we get the following messages:

<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <userExists? user:<username>>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <getConnection return conn:LDAPConnection { ldapVersion:2 bindDN:""}>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <getDNForUser search("ou=people,ou=<wls_security_realm_name>,dc=<wls_domain_name>", "(&(uid=<username>)(objectclass=person))", base DN & below)>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <DN for user <username>: null>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <returnConnection conn:LDAPConnection { ldapVersion:2 bindDN:""}>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <user does not exist, user:<username>>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <userExists? user:<username>>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <getConnection return conn:LDAPConnection {ldaps://<ldap.host.domain>:<ldap_port> ldapVersion:3 bindDN:"cn=<CommonName1>,OU=<OrganizationUnit>,dc=<DomainComponent1>,dc=<DomainComponent2>,DC=com"}>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <getDNForUser search("OU=<OrganizationUnit>,dc=<DomainComponent>,DC=com", "(&(&(cn=<username>)(objectclass=person))(!(userAccountControl:<UAC#>:=2)))", base DN & below)>

<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <DN for user <username>: null>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecuritySSL> <BEA-000000> <isMuxerActivated: false>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <returnConnection conn:LDAPConnection {ldaps://<ldap.host.domain>:<ldap_port> ldapVersion:3 bindDN:"cn=<CommonName1>,OU=<OrganizationUnit>,dc=<DomainComponent1>,dc=<DomainComponent2>,DC=com"}>
<Jul 18, 2011 7:25:58 PM CDT> <Debug> <SecurityAtn> <BEA-000000> <user does not exist, user:<username>>

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.