My Oracle Support Banner

WebLogic Proxy Plugin Load Balancing Issue with Unicast Cluster (Doc ID 1345308.1)

Last updated on NOVEMBER 05, 2016

Applies to:

Oracle Weblogic Server - Version 10.3 and later
Information in this document applies to any platform.
***Checked for relevance on 19-Mar-2013***

Symptoms

In WebLogic Server 10.3 and above, an issue was reported of load balancing not working properly with  Managed servers which are part of a Unicast Cluster when using the Apache web server. At the time of the issue, requests from the Apache proxy server are getting routed to the same Managed Server instance in the Unicast Cluster.

With below Cluster and Unicast Debug flags enabled "java.io.IOException: Channel not yet bound" exceptions were seen in debug logs:

DebugCluster
DebugUnicastMessaging (for Unicast mode only)
DebugClusterFragments
DebugClusterHeartbeats

Below is the exception message with the above cluster and Unicast debug flags enabled:

Line 759: ####<Jul 14, 2011 5:13:55 PM CEST> <Debug> <UnicastMessaging> <lena> <msps5c1_m1_msps5n1> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1310656435445> <BEA-000000> <[GroupMember] Failed to send message to msps5c1_m1_msps5n2> Excpetion:java.io.IOException: Channel not yet bound!>
Line 760: ####<Jul 14, 2011 5:13:55 PM CEST> <Debug> <UnicastMessaging> <lena> <msps5c1_m1_msps5n1> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1310656435446> <BEA-000000> <[GroupMember] Failed to send message to msps5c1_m1_msps5n2> Excpetion:java.io.IOException: Channel not yet bound!>
Line 761: ####<Jul 14, 2011 5:13:55 PM CEST> <Debug> <UnicastMessaging> <lena> <msps5c1_m1_msps5n1> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1310656435447> <BEA-000000> <[Group] [LocalGroup [[msps5c1_m1_msps5n1, msps5c1_m1_msps5n2]]] removeFromRunningSet msps5c1_m1_msps5n2>
Line 762: ####<Jul 14, 2011 5:13:55 PM CEST> <Debug> <UnicastMessaging> <lena> <msps5c1_m1_msps5n1> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <> <1310656435448> <BEA-000000> <[Group] [LocalGroup [[msps5c1_m1_msps5n1]]] server msps5c1_m1_msps5n1, id=1310656435442 send failed to msps5c1_m1_msps5n2>
Line 767: ####<Jul 14, 2011 5:13:55 PM CEST> <Debug> <UnicastMessaging> <lena> <msps5c1_m1_msps5n1> <Timer-2> <> <> <> <1310656435690> <BEA-000000> <[Group - PingRoutine] Successfully pinged msps5c1_m1_msps5n2>
Line 768: ####<Jul 14, 2011 5:13:55 PM CEST> <Debug> <UnicastMessaging> <lena> <msps5c1_m1_msps5n1> <Timer-2> <> <> <> <1310656435692> <BEA-000000> <[Group]

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.