Unable to create a Directory Server instance after installing Directory Server 6.3, gives error "ld.so.1: dsadm: fatal: libnss3.so: version `NSS_3.4' not found (required by file dsadm)". (Doc ID 1362225.1)

Last updated on OCTOBER 11, 2016

Applies to:

Oracle Directory Server Enterprise Edition - Version 6.3 and later
Information in this document applies to any platform.
***Checked for relevance on 03-11-2013***
***Checked for relevance on 08-17-2014***

Goal

Problem Description:
The following error message is reported when trying to create a DSEE instance from CLI

./dsadm create <instance-path>
ld.so.1: dsadm: fatal: libnss3.so: version `NSS_3.4' not found (required by file dsadm)
ld.so.1: dsadm: fatal: libnss3.so: open failed: No such file or directory



Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms