Opensso: Unable To Let Run updateschema.sh (Doc ID 1364268.1)

Last updated on SEPTEMBER 21, 2016

Applies to:

Oracle OpenSSO - Version: 8.0.2 and later   [Release: 8.0 and later ]
Information in this document applies to any platform.

Symptoms


On Applications : OpenSSO 8.0Update2 patch3
When attempting to updateschema.sh script , the following error occurs.

-- Error
./updateschema.sh
get_ssoadm_path...
Path of ssoadm tool: /opt/tools/admintool/opensso/bin
get_amadmin_password...
amadmin password:
validate_amadmin_password...
/opt/tools/admintool/opensso/bin/ssoadm list-server-cfg -s default -u amadmin -f ssoadm.pw.file -O
Exception in thread "main" java.lang.ExceptionInInitializerError
       at java.lang.Class.forName0(Native Method)
       at java.lang.Class.forName(Unknown Source)
       at com.sun.identity.cli.SubCommand.execute(SubCommand.java:289)
       at com.sun.identity.cli.CLIRequest.process(CLIRequest.java:230)
       at com.sun.identity.cli.CLIRequest.process(CLIRequest.java:139)
       at com.sun.identity.cli.CommandManager.serviceRequestQueue(CommandManager.java:585)
       at com.sun.identity.cli.CommandManager.<init>(CommandManager.java:181)
       at com.sun.identity.cli.CommandManager.main(CommandManager.java:145)
Caused by: com.sun.identity.security.AMSecurityPropertiesException: AdminTokenAction:  FATAL ERROR: Cannot obtain Application SSO token.
Check AMConfig.properties for the following properties
       com.sun.identity.agents.app.username
       com.iplanet.am.service.password
       at com.sun.identity.security.AdminTokenAction.run(AdminTokenAction.java:258)
       at java.security.AccessController.doPrivileged(Native Method)
       at com.sun.identity.cli.AuthenticatedCommand.<clinit>(AuthenticatedCommand.java:64)
       ... 8 more
Your input is invalid, error code is 1, please try again
get_amadmin_password...
amadmin password:

-- Expected Behaviour
ssoadm tool runs without exception

-- Steps
The issue can be reproduced at will with the following steps.
1. apply OpenSSO 8.0 Update 2 Patch 3 war
2. update ssoadm tool
3. run updateschema.sh (used ssoadm)

-- Business Impact
The issue has the following business impact:
customer could not upgrade the OpenSSO schema - which is required that OpenSSO runs correct.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms