Admin Server fails to start as a Windows Service when using -Dhttp.nonProxyHosts (Doc ID 1371184.1)

Last updated on NOVEMBER 05, 2016

Applies to:

Oracle Weblogic Server - Version 10.3.4 and later
Microsoft Windows (32-bit)

Symptoms


Not able to start the AdminServer after installing the server as service.

In the server logs we get below exception:

[Wed Oct 05 09:47:36 2011] [I] [RunJavaApp] Loading class - localhost|localhost.localdomain|hostname|IP|IP|IP|IP|IP|devapp|hostname|soauat|devappservervs|hostname|IP|IP|IP|IP|IP|devapp|hostname|soauat|devappservervs|*.host\
java.lang.NoClassDefFoundError: localhost|localhost/localdomain|hostname|10/131/217/160|10/128/214/241|10/128/214/211|10/128/214/112|10/128/214/142|devapp|soauat/portal/nv/gov|soauat|devappservervs|*devapp/devsos/state/nv/us*|uatappservervs|IP|*/portal/nv/gov\
Caused by: java.lang.ClassNotFoundException: localhost|localhost.localdomain|hostname|IP|IP|IP|IP|IP|devapp|hostname|soauat|devappservervs|hostname|IP|IP|IP|IP|IP|devapp|hostname|soauat|devappservervs|*.host\
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
[Wed Oct 05 09:47:41 2011] [I] [ServiceStart] trying to open a connection to host
[Wed Oct 05 09:47:41 2011] [I] [ServiceStart] connection attempt failed. retrying
[Wed Oct 05 09:47:46 2011] [I] [ServiceStart] trying to open a connection to host
[Wed Oct 05 09:47:46 2011] [I] [ServiceStart] connection attempt failed. retrying
[Wed Oct 05 09:47:51 2011] [I] [ServiceStart] Reporting SCM of SERVICE_RUNNING
[Wed Oct 05 09:47:51 2011] [I] [ServiceStart] waiting for multiple events
[Wed Oct 05 09:47:51 2011] [I] [ServiceStart] done waiting for multiple events. Wait=1
[Wed Oct 05 09:47:51 2011] [E] [ServiceStart] Error in JVM. Cause=Unable to load main class!
[Wed Oct 05 09:47:51 2011] [I] [ServiceStart] Informing SCM about SERVICE_STOP

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms