WC_Utilities Fails to Start on zLinux and IBM AIX due to activitygraph-engines Initialization Failure (Doc ID 1376372.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle WebCenter Portal - Version: 11.1.1.4.0 and later   [Release: 11g and later ]
Information in this document applies to any platform.

Symptoms


This problem can happen on a standard WebCenter environment running on IBM AIX or zLinux platforms.  The problem does not occur on other platforms.

WC_Portlet, WC_Collaboration and WC_Spaces components are starting ok and in a running state, but  the WC_Utilities managed server is failing to start and showing ADMIN status in the WebLogic Server console .
 The following error stack is seen in the WC_Utilities log file.  The underlying error is Failed to load webapp: '/activitygraph-engines'. This in turn means the WC_Utilities managed server cannot start up successfullt.

<Error> <Deployer> <...> <WC_Utilities_1> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <> <> <0000J5DGZ9G4ulU6y7fd6G1EA48F000002> <1311261226661>
<BEA-149205> <Failed to initialize the application 'activitygraph-engines [Version=11.1.1.4.0]' due to error weblogic.application.ModuleException: Failed to load webapp: '/activitygraph-engines'.

weblogic.application.ModuleException: Failed to load webapp: '/activitygraph-engines'
at weblogic.servlet.internal.WebAppModule.prepare(WebAppModule.java:393)
at weblogic.application.internal.flow.ScopedModuleDriver.prepare(ScopedModuleDriver.java:176

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms