"Deployment Failed - ORABPEL-05250" and "RuntimeException: cannot adapt to Storage.class - must not happen" Errors after Upgrading to 11.1.1.6 (Doc ID 1442328.1)

Last updated on OCTOBER 18, 2016

Applies to:

Oracle SOA Suite - Version 11.1.1.6.0 to 11.1.1.6.0 [Release 11gR1]
Information in this document applies to any platform.
***Checked for relevance on 29-November-2013***

Symptoms

After upgrading from an earlier SOA Suite version to PS5 (11.1.1.6.0) you might encounter the following issue when trying to deploy some of your SOA composite applications. This is the error shown in Enterprise Manager:

ORABPEL-05250

Error deploying BPEL suitcase.
error while attempting to deploy the BPEL component file "<some_bpel_component_here>"; the exception reported is: java.lang.RuntimeException: cannot adapt to Storage.class - must not happen


The following error is observed in the logs:

[ERROR] [] [oracle.soa.bpel.engine.deployment] [tid: ReplicatedCache:soa_acp_soa_acp_clusterCacheService:EventDispatcher] [userId: <anonymous>] [ecid: 0000JOBvhARDOdQh6_ECSi1FNnRv000002,1:21493] [APP: soa-infra] [[
java.lang.RuntimeException: cannot adapt to Storage.class - must not happen
at com.collaxa.cube.engine.ext.bpel.common.BaseBPELCubeElement.adapt(BaseBPELCubeElement.java:110)
at com.collaxa.cube.engine.ext.bpel.common.BaseBPELCubeElement.store(BaseBPELCubeElement.java:116)
at com.collaxa.cube.engine.ext.bpel.common.BaseBPELCubeBlock.setSkipCondition(BaseBPELCubeBlock.java:114)
at orabpel.employmentprocess.BpScp$BpScp4.init(BpScp.java:287)
at com.collaxa.cube.engine.ext.bpel.common.BaseBPELCubeElement.<init>(BaseBPELCubeElement.java:59)
at com.collaxa.cube.engine.ext.bpel.common.BaseBPELCubeBlock.<init>(BaseBPELCubeBlock.java:53)
at com.collaxa.cube.engine.ext.bpel.v1.blocks.BaseBPEL1Block.<init>(BaseBPEL1Block.java:18)
at com.collaxa.cube.engine.ext.bpel.v1.blocks.BPELScopeBlock.<init>(BPELScopeBlock.java:50)
at orabpel.employmentprocess.BpScp$BpScp4.<init>(BpScp.java:277)
at orabpel.employmentprocess.BIN0.addMaps$process$0(BIN0.java:791)
at orabpel.employmentprocess.BIN0.addMaps$process(BIN0.java:48)
at orabpel.employmentprocess.BPEL_BIN.buildMaps(BPEL_BIN.java:336)
......


The error might also occur on a fresh SOA Suite 11.1.1.6.0 installation.

Changes

This can occur when upgrading the SOA Suite version 11.1.1.6.0 (PS5).

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms