My Oracle Support Banner

Use of OAM 11g Policy Failure URL With Client With Javascript Disabled Causes Error "JavaScript is required. Enable JavaScript to use OAM Server." (Doc ID 1447194.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle Access Manager - Version: 11.1.1.5.0 and later   [Release: and later ]
Information in this document applies to any platform.

Symptoms

Oracle Access Manager (OAM) 11.1.1.5 has been configured with a Failure URL for a Protected Authentication or Authorization Resource Policy.

This works for access to OAM-protected resources from client browsers that have Javascript enabled.

However if the client has Javascript disabled then the redirect to the Failure URL does not work, instead the following message is displayed to the user:

JavaScript is required. Enable JavaScript to use OAM Server.



Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.