My Oracle Support Banner

GoldenGate Replicat abend with "OGG-01332 File dirdat\xx, with compatibility level 3, is not compatible with the current software version's compatibility level of 2 (Doc ID 1451840.1)

Last updated on MARCH 28, 2018

Applies to:

Oracle GoldenGate - Version 10.0.0.0 and later
Information in this document applies to any platform.

Symptoms

Replicat abending with the following error after a source OGG upgrade.

2012-04-06 09:21:56  ERROR   OGG-01332  File dirdat\pj000088, with compatibility level 3, is not compatible with the current software version's compatibility level of 2. Modify the file writer's parameter file to generate the appropriate format using the FORMAT LEVEL 2 option.

OR

2012-04-05 19:49:22  GGS ERROR    ZZ-0QE  File header failed to parse tokens. File dirdat\pj000025, last offset 905, data: 905: 000000013A00000200003B000004000000013C0000140000001014141414141414141414141411141414330000773000000A0008454F42415232363131000002000332000002000B33000002000234000002000135000002000036000002000137000041003F56657273696F6E2031312E322E312E302E30204F4747434F5245.

The same error could happen when doing a initial load with different OGG versions 

 

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.