My Oracle Support Banner

Deployment Hang "Error getting http port details from JRF API" In A SOA Cluster On Webshpere which disabled HTTP port with only SSL enabled (Doc ID 1453467.1)

Last updated on AUGUST 01, 2017

Applies to:

Oracle SOA Suite - Version 11.1.1.4.0 and later
Information in this document applies to any platform.

Symptoms

We have a SOA cluster with two servers running on Webshpere with only SSL secure port enabled.

An application was build on Jdev 11 and tested on local WAS 7 server which was fine. 

Attempting to deploy it to the SOA cluster from EM console, we are unable to select the service when attempting Step 3 (Deploy) button.  The screen stays still and there is no
progress after that. Checking the emoms logs in Admin Server folders, we can see the following error

ERROR

[2012-03-19T16:17:04.889+11:00] [BPLADMTSTC1WASAUTSTDT151S01] [NOTIFICATION:24] [] [oracle.sysman.emai.model.sca.util.SCAInfraWASConnectionHelper] [tid: WebContainer : 2] [ecid: 0000JOdOmFQ5aaQ5qb9DiY1FPeT20001Ix,0] [APP: em] Error getting http port details from JRF API
[2012-03-19T16:17:04.889+11:00] [BPLADMTSTC1WASAUTSTDT151S01] [NOTIFICATION:32] [] [oracle.sysman.emai.model.sca.util.SCAInfraWASConnectionHelper] [tid: WebContainer : 2] [ecid: 0000JOdOmFQ5aaQ5qb9DiY1FPeT20001Ix,0] [APP: em] Error getting http port details from JRF API[[
java.lang.NullPointerException
at oracle.sysman.emai.model.sca.util.SCAInfraWASConnectionHelper.getPort(SCAInfraWASConnectionHelper.java:131)
at oracle.sysman.emai.model.sca.util.SCAInfraBaseConnectionHelper.getHttpPort(SCAInfraBaseConnectionHelper.java:82)
at oracle.sysman.emai.model.sca.deploy.WASSOADeployTargetInfo.retrieveConnectionInfos(WASSOADeployTargetInfo.java:71)
at oracle.sysman.emai.model.sca.deploy.SOADeployTargetInfo.getConnectionInfos(SOADeployTargetInfo.java:173)
at oracle.sysman.emai.model.sca.deploy.DeployModel.execute(DeployModel.java:428)
at oracle.sysman.emai.view.sca.deploy.DeployWizardSelectArchiveViewBean.goTask(DeployWizardSelectArchiveViewBean.java:628)

 

Changes

If we enable the HTTP port on SOA Server (inbound default host) we are able to deploy service.

Since the requirement is to use secure port only , we disabled the default host (HTTP) and then the deployment fails.

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.