Portlets No Longer Appear On a WCI Page and A View Source of the Page Shows Java.lang.NullPointerException Messages (Doc ID 1463819.1)

Last updated on DECEMBER 02, 2016

Applies to:

Oracle WebCenter Interaction - Version 6.5 and later
Information in this document applies to any platform.

Symptoms

Previously working portlets no longer appear on WCI portal pages. For example, a custom header and login portlet no longer appear, preventing users from accessing content. Instead the following message was returned:

The server encountered an error. Try again or contact the portal administrator if you continue to have problems.

At the same time the following errors were seen in in a PTSPY log.

Warning Community portal.hostname.oracle [ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)' com.plumtree.server.impl.community.PTMyPortalGadgetContent PTMyPortalGadgetContent.GetGadget:  Unable to init the gadget entry for 0. <ptLogMsgEnd>


Error UI_Infrastructure portal.hostname.oracle [ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)' com.plumtree.uiinfrastructure.interpreter.Interpreter Unable to process request.
java.lang.NullPointerException
at com.plumtree.portalpages.browsing.myportal.MyPortalModel$MyPortalModelTempData.InitializePortletContent(MyPortalModel.java:2369)
...

Error UI_Infrastructure portal.hostname.oracle [ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)' com.plumtree.uiinfrastructure.interpreter.Interpreter Server error.
java.lang.NullPointerException

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms