My Oracle Support Banner

Mod_osso Is Not Working Properly After Following Note ID 422359.1 (Doc ID 1466030.1)

Last updated on NOVEMBER 05, 2019

Applies to:

Oracle Application Server Single Sign-On - Version 10.1.4.0.1 to 10.1.4.3 [Release 10gR3]
Information in this document applies to any platform.
***Checked for relevance on 04-NOV-2019***

Symptoms

1. After configuring Apache Reverse proxy following note ID 422359.1.
2. Portal(/pls/portal) and SSO urls (such as /sso,/pls/orasso,/oiddas) and mod_osso protecting static pages where SSO/DAS run are working fine. Lets say follow

URL’s protected with SSO work fine:

http://<PROXY_VIRTUAL_HOST_SERVERNAME>:<HTTP_PROXY_PORT>/oiddas
http://<PROXY_VIRTUAL_HOST_SERVERNAME>:<HTTP_PROXY_PORT>/pls/orasso
http://<PROXY_VIRTUAL_HOST_SERVERNAME>:<HTTP_PROXY_PORT>/private/index.html ---> Static page on SSO/DAS server (mod_osso)
http://<PROXY_VIRTUAL_HOST_SERVERNAME>:<HTTP_PROXY_PORT>/pls/porta/

3. But whenever any static resource protected by mod_osso loaded by OHS running in the Portal middle the SSO page comes up. After entering username/password

the page just hangs. Lets says follow URL presenting issue:

 http://<PROXY_VIRTUAL_HOST_SERVERNAME>:HTTP_PROXY_PORT/private2/index.html ---> Static page on OHS/Portal middle tier server (mod_osso) presenting issue.

Log file shows this information:

[Mon Apr 2 17:33:21 2012] [debug] mod_osso.c(4323): [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] ===== REQUEST =====\n[OSSO] GET /TEST/test.html HTTP/1.1\n
[Mon Apr 2 17:33:21 2012] [debug] mod_osso.c(2885): [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] D01: authenticate_user()\n
[Mon Apr 2 17:33:21 2012] [debug] mod_osso.c(510): [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] D26: process_idle_time()\n
[Mon Apr 2 17:33:21 2012] [debug] mod_osso.c(844): [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] D02: unpack_cookie()\n
[Mon Apr 2 17:33:21 2012] [debug] mod_osso.c(1983): [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] D09: decrypt_cookie()\n
[Mon Apr 2 17:33:21 2012] [warn] [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] W16: OHS-http://<SSO_HTTP_SERVERNAME>:<HTTP_PORT>-<HTTP_DEFAULT_PORT> cookie corrupted.\n
[Mon Apr 2 17:33:21 2012] [debug] mod_osso.c(2937): [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] D15: Invalid OHS-http://<SSO_HTTP_SERVERNAME>:<HTTP_PORT>-<HTTP_DEFAULT_PORT> cookie. Redirect to SSO server.\n
[Mon Apr 2 17:33:21 2012] [debug] mod_osso.c(1233): [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] D05: make_query_string()\n
[Mon Apr 2 17:33:21 2012] [debug] mod_osso.c(1873): [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] D30: Time sent: 1333368201, gmtime: 21, time returned: 3:12:2 Month:3 Mday:112 Year:1\n
[Mon Apr 2 17:33:21 2012] [debug] mod_osso.c(1907): [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] D33: Timestamp string: 20120402120321\n
[Mon Apr 2 17:33:21 2012] [debug] mod_osso.c(1155): [client <IP_ADDRESS>] [ecid: <ECID>] \n[OSSO] D04: des_encrypt()\n

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.