OAM Console Starts with Error, Invalid Store Resource Name HTTP..., then no Data Displayed

(Doc ID 1469924.1)

Last updated on OCTOBER 19, 2016

Applies to:

Oracle Access Manager - Version 11.1.1.5.0 and later
Information in this document applies to any platform.

Symptoms

Start the OAM console, get the error abut an "invalid store resource name.." Click OK to continue, and no configuration data is found.
Issue did not occure until adding the unprotected resource (See below).

Steps to reproduce the issue:
============================
1. Open new browser session and enter the following URL:
http://oamservername.domain:7001/oamconsole

2. Login page is displayed

3. Enter username/pwd

4. Console is displaied and we see the following error:
Invalid store resource name HTTP:a78a904e1f693471682c811c59531de65: /test/f?p=109%3A2*.

5. Select ok...

Now no policy data is displayed

 

Additional information:

Created a resource within an Application Domain via OAM console like below - /test/f?p=109:2
While creating, this gave an error so changed the resource to - /test/f?p=109%3A2
That resource got created successfully. However, now when trying to log into OAMConsole, keep getting the following error - -

"Invalid store resource name HTTP:abe4b498abad44fd7bda51fbd6280565f:/test/f?p=109:2"

This error causes nothing to be displayed in the Policy Configuration tree on the left side of the page.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms