My Oracle Support Banner

In-Process Report Server Fails to Start, with REP-51002 error in rwserver_diagnostic and UnsatisfiedLinkError Error in AdminServer diagnostics log (Doc ID 1509204.1)

Last updated on FEBRUARY 23, 2019

Applies to:

Oracle Reports Developer - Version 11.1.1.4.0 to 11.1.2.1.0 [Release 11g]
Generic Linux

Symptoms

In-process reports server fails to start. This is new install / upgrade to 11.1.1.4. The following logs were seen in rwserver_diagnostic log file

rwservlet_diagnostic.log
[2012-11-27T03:15:53.322-06:00] [WLS_REPORTS] [INCIDENT_ERROR] [REP-51002] [oracle.reports.servlet] [tid: 16] [userId: <anonymous>] [ecid: <ecid>] [APP: reports#11.1.1.2.0] [URI: /reports/rwservlet/getserverinfo] REP-51002 : Bind to Reports Server rep_wls_reports_<hostnasme>_<instancename> failed.  [[
oracle.reports.RWException: IDL:oracle/reports/RWException:1.0
at oracle.reports.utility.Utility.newRWException(Utility.java:1053)
at oracle.reports.client.ServerManager.getServer(ServerManager.java:284)
at oracle.reports.client.ServerManager.isSecure

 and

Error : "OFM-99998 [oracle.reports.util.EnvironmentGlobal][java.lang.UnsatisfiedLinkError]"

 was seen in logsAdminServer-diagnostic.log file

Changes

 The system was just upgraded to 11.1.1.4

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.