When Installing A User Certificate Orapki Throws Error - Could not install user cert. Please add all trusted certificates before adding the user certificate (Doc ID 1529589.1)

Last updated on JULY 26, 2017

Applies to:

Oracle HTTP Server - Version 10.1.3.1.0 and later
Oracle Fusion Middleware - Version 10.1.2.0.0 and later
Oracle Internet Directory - Version 10.2.1.0 and later
Information in this document applies to any platform.

Symptoms

When using the orapki command line interface to add a user certificate to an existing wallet, the following error is generated:


Possible causes of the error:


- Input was not a valid certificate
- No matching certificate request was found
- CA certificate needed for certificate chain not found. Please install it first.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms