My Oracle Support Banner

WebLogic Server Web 服务器 Plug-in 支持 (Doc ID 1531810.1)

Last updated on AUGUST 20, 2019

适用于:

Oracle WebLogic Server - 版本 9.2 和更高版本
本文档所含信息适用于所有平台

详细信息

适用于:

请注意,本文并不适用于Oracle HTTP Server(OHS)。有关 Oracle WebLogic Server Plug-In 1.1 对 Oracle HTTP Server 11g 的支持的信息,请参阅以下文章:

WebLogic Server 10g Plug-In(之前称为 1.0 版)、WebLogic Server 11g Plug-In(之前称为 1.1 版)和 WebLogic Server 12c Plug-In

我们建议需要 WebLogic Server Web 服务器 plug-in 支持的客户查看本文档。Oracle WebLogic Server Web 服务器 plug-in 通过担任前端代理在所有 WebLogic Server 受管服务器间提供负载平衡。这些 plug-in 是以原生代码(而非 Java)编写的,因此它们特定于使用它们的操作系统。因此,我们无法使用常规 WLS 的打补丁过程对其进行修补:它们的修复方法不同于 Java 代码。因此,在需要修复 plug-in的bug 时,不能通过打补丁方式来完成修复,而应将原生代码完整替换为新版本。

自 WebLogic Server 11g 起,每个 plug-in 都会有一个与 Fusion Middleware 版本号对应的版本号 (11.1.1.x)。此版本号将替换之前使用的编号系统。适用于 11g 之前的 WLS 的 plug-in 以前被称为 1.0 版 plug-in,而现在已经被重命名为 WebLogic Server 10g plug-in。适用于 WLS 11g 的 plug-in 现在名为 WebLogic Server 11g plug-in,该名称由之前的 1.1 版 plug-in 更名而来。针对 WebLogic Server 12c plug-in已经发布,并且12c plug-in认证了WebLogic Server 11g和WebLogic Server 12c,我们建议所有使用64bit web server(参考下边内容)的客户在WebLogic Server 11g和12c上使用12c plug-in。

功能差异

直到10.3.x,WLS 10g plug-in 是与 WebLogic Server一起封装的。但是,10g plug-ins并没有与WebLogic Server 12c封装在一起,他们不应该与WLS 12c共同使用。在一定程度上,这些 plug-in 一直独立于 WebLogic Server 本身而存在:10g plug-in 适用于 WLS 10.3.x 及更低版本,对这些 plug-in 所进行的修复(将 plug-in 替换为修复后的版本)也适用于相同版本的 WLS。

WLS 11g plug-in增强了 10g plug-in 的一些功能,并可解决 1.0 版 plug-in 的某些不足之处。11gplug-in 的增强功能亮点如下:

WLS 11g plug-in 针对与 WLS 11g 一起使用进行了优化,并仅在WLS 11g (WLS 10.3.1+)上进行了官方测试。由于没有在旧版本的WLS上进行测试,我们不能完全保证新版本的plug-in可以和旧版本WLS完全兼容。但是,除了上述局限性外,我们预期新版本plug-in将会向后兼容于旧版本的WLS。我们鼓励使用11g WLS以前版本的客户升级到11g或者更高版本,以便使用已针对目标 WLS 版本进行优化的 plug-in。有关不同 plug-in 版本功能支持的详细信息,请参阅 WebLogic Server 随附的 plug-in 文档。

平台支持

WLS 10g plug-in是为32bit的Apache,iPlanet和IIS Web Servers设计的,并支持以下平台:Linux,Solaris (SPARC, x86),AIX (POWER)和 HP-UX (PA-RISC)。支持的操作系统版本由WLS 10g在这些平台上支持的操作系统版本决定。

WLS 11g plug-in支持以下版本:

    Linux上运行的Apache 2.2 (32-bit)
    Windows,Linux,HP-UX (PA-RISC, Itanium),AIX (POWERPC),Solaris (SPARC, x86)上运行的Apache 2.2 (64-bit)
    Linux上运行的iPlanet 7.0 (32-bit)
    Linux和Solaris (SPARC, x86)上运行的iPlanet 7.0 (64-bit)
    Windows上运行的IIS (64-bit)

WebLogic Server Plug-In 11.1.1.5+ 在HP-UX (Itanium)上支持Apache 2.2。WebLogic Server Plug-In 11.1.1.7+ 在Solaris SPARC上还支持iPlanet Web Server 6.1 SP17 (64-bit)。

WLS 12c plug-in只应用于64-bit Web Servers。这个信息可在Fusion Middleware 12.1.2认证表格中获得(在Web Server页面中)。认证表格(http://www.oracle.com/technetwork/middleware/ias/downloads/fusion-certification-100350.html)列出了plug-in 所支持的Web Server版本,操作系统产品以及芯片结构。

对于某个 plug-in 支持的给定的操作系统产品(例如 Solaris)和芯片结构,该 plug-in 支持其连接的 WebLogic Server 版本所支持的操作系统版本(例如 Solaris 10)。有关特定的操作系统版本支持,请参阅 WebLogic Server 文档。如果需要从单个 plug-in 代理连接到多个版本的 WebLogic Server时, plug-in仅支持所有这些WebLogic Server 版本都支持的操作系统版本。

物理封装

直到WLS 10.3.6,WLS 10g plug-in 与 WebLogic Server 安装程序捆绑提供。WLS 11g 和更新版本的 plug-in 不与 WebLogic Server 安装程序捆绑在一起。WebLogic Server 12c (12.1.1及更高版本)没有绑定任何plug-in。如果需要,plug-in可以单独下载和安装。请参阅以下说明下载 WLS 10g 和 WLS 11g 以及更高版本的plug-in的最新维护版本。

下载 plug-in 的最新维护版本

客户可在My Oracle Support 上通过补丁编号<Patch 10051798>下载WLS 10g plug-in的最新版本。对于WLS 11g 和12c的plug-ins,可从Oracle Technology Network (OTN http://www.oracle.com/technetwork/middleware/webtier/downloads/index.html)上下载。

针对使用 WLS 11g 和更高版本 plug-in 的一般建议:

WLS 10g(1.0 版)plug-in 已被弃用,这意味着 11gR1以后的WebLogic Server 版本(包括WebLogic 12c,12.1.1 及更高版本)将不支持WLS 10g plug-in。WLS 10g plug-in 已经过了标准支持期。考虑到 WLS 11g 和更高版本 plug-in 提供的新功能,我们鼓励客户在适用的项目中使用 WLS 11g 或更高版本的 plug-in。

操作



联系人

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


文档内容
详细信息
 适用于:
 WebLogic Server 10g Plug-In(之前称为 1.0 版)、WebLogic Server 11g Plug-In(之前称为 1.1 版)和 WebLogic Server 12c Plug-In
 功能差异
 平台支持
 物理封装
 下载 plug-in 的最新维护版本
 针对使用 WLS 11g 和更高版本 plug-in 的一般建议:
操作
联系人
 更多资源
参考

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.