Is it Supported to Upgrade the JDK in theForms ORACLE_HOME of an 11gR1 or 11gR2 Forms & Reports Installation to JDK 1.7.0_XX ?

(Doc ID 1554189.1)

Last updated on FEBRUARY 21, 2018

Applies to:

Oracle Forms - Version 11.1.1.4.0 to 11.1.2.1.0 [Release 11g]
Oracle Reports Developer - Version 11.1.1.6.0 to 11.1.2.1.0 [Release 11g]
Information in this document applies to any platform.

Symptoms

 NOTE: This note is "not" referring to the JDK that comes with WLS. This note is referring to the JDK that comes in a default installation of Forms and Reports and exists in the Forms ORACLE_HOME/jdk directory.

For information about JDK versions related to WLS see the following resources:

<Note 1309855.1> How to Upgrade the JDK Used by Oracle WebLogic Server 11g to a Different Version and Certification Information for the specific version involved.

Upgrading the JDK in the Forms ORACLE_HOME/jdk directory to JDK 1.7 is only supported in the terminal version of  11gR2 Forms and Reports version - 11.1.2.2.  It is not supported with earlier versions such as  11.1.2.0 and 11.1.2.1.  It is not supported with any 11gR1 Forms and Reports version which includes the terminal version of  11gR1 - 11.1.1.7 - or any earlier 11gR1 version.

 By default, the JDK installed in the Forms/Reports ORACLE_HOME/jdk driectory is JDK 1.6.  For example, in 11.1.2.2 this version is 1.6.0_35.

If you upgrade the JDK in the Forms ORACLE_HOME/jdk directory to JDK 1.7 for any version other than 11.1.2.2,  your Forms installation will no longer function.  You will receive FRM-93552 errors.  Notes such as <Note 1345748.1> do not apply since JDK 1.7 does not have libhpi.so.

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms