Oracle Weblogic Server 12.1.1: WELD-001208 Errors Deploying Application Using Spring Framework Version 3 (Doc ID 1555301.1)

Last updated on JUNE 09, 2016

Applies to:

Oracle Weblogic Server - Version 12.1.1.0 and later
Information in this document applies to any platform.

Symptoms

Customer is seeing many beans.xml parsing errors while deploying an application to WLS 12.1.1. The same application worked correctly in WLS 10.3.6. Many errors like the following are seen in the logs:

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms