The Upgrade Assistant (UA) Fails To Launch On Solaris SPARC 10 With java.lang.InternalError: Can't connect to X11 window server using 'myhost:11.0' as the value of the DISPLAY variable (Doc ID 1561659.1)

Last updated on NOVEMBER 05, 2016

Applies to:

Oracle Fusion Middleware - Version 11.1.1.2.0 and later
Oracle Solaris on SPARC (64-bit)

Symptoms


This is an Oracle Application Server 10.1.2.3.0 BI & Forms midtier which needs to be upgraded to Fusion Middleware 11g. The installations of Oracle Application Server 10.1.2.3.0 BI & Forms and Fusion Middleware Portal, Forms, Reports, Discoverer 11.1.1.6.0 have been performed on the same machine. The  Operating system has been upgraded from Solaris SPARC 10 64-bit Upgrade 8 to Upgrade 10.


When trying to upgrade the configuration using the Upgrade Assistant $ORACLE_HOME/bin/ua script the following error is thrown on the screen:

 

 

This error is just experienced when running the Upgrade Assistant, but is not reproduced when running the Installation or Configuration of the Portal, Forms, Reports, Discoverer 11.1.1.6.0 environment.

The same error was observed in the TRUSS file that was created when executing the Upgrade Assistant $ORACLE_HOME/bin/ua script.

 

Changes

Customer applied Solaris SPARC 10 update 10 (from U8) released on Feb 6, 2013.
Kernel ver. 147147-26: (from 147440-12)
(SunOS monty 5.10 Generic_147147-26 sun4u sparc SUNW,Sun-Fire-V440)

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms