After Upgrade 11g Instance is Referencing Some Libraries Of Old 6.3.1 Binaries (Doc ID 1569947.1)

Last updated on OCTOBER 06, 2016

Applies to:

Oracle Directory Server Enterprise Edition - Version 7.0 and later
Information in this document applies to any platform.

Symptoms

 After performing the upgrade from DSEE6.3 to DSEE 7.0 (or ODSEE 11.1.1.7), the upgraded DS instance is still referencing the DSEE 6.3 libraries.

Eg,

.Perform upgrade,

#./dsee7/bin/dsadm upgrade /dsee63/instances/ds11389
Directory Server instance '/dsee63/instances/ds11389' will be upgraded to version 7.
It will no longer be usable with DSEE 6 commands.
Do you want to continue [y/n]? y
Moving legacy scripts into '/dsee63/instances/ds11389/bak/2013-07-18-16-16-51' ...
Adding new files to instance ...
Upgrading dse.ldif ...
Old version of dse.ldif has been moved into '/dsee63/instances/ds11389/bak/2013-07-18-16-16-51'.                                                                                                                                                                            

Directory Server instance '/dsee63/instances/ds11389' is now ready to be used with DSEE 7 commands.

.Start the upgraded DS instance,

#./dsee7/bin/dsadm start /dsee63/instances/ds11389
Waiting for Directory Server instance '/dsee63/instances/ds11389' to start...
Directory Server instance '/dsee63/instances/ds11389' started: pid=28770

.Check the libraries,

# pldd 28770

...

/dsee7.0/lib/sparcv9/private/libnssdbm3.so
/dsee63/dsee6/private/lib/sparcv9/libnssckbi.so
/dsee63/dsee6/private/lib/sparcv9/libplc4.so
/dsee63/dsee6/private/lib/sparcv9/libplds4.so
/dsee63/dsee6/private/lib/sparcv9/libnspr4.so

Changes

 Upgrade from DSEE 6.3 to DSEE 7.0 (or ODSEE 11.1.1.7).

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms