Error - Policy Store version 11.1.1.7.0 and Oracle Platform Security Services Version 11.1.1.5.0 are not compatible (Doc ID 1584069.1)

Last updated on JUNE 11, 2014

Applies to:

Oracle Access Manager - Version 11.1.1.7.0 and later
Information in this document applies to any platform.

Symptoms

Trying to upgrade OAM from 11.1.1.5 to 11.1.1.7.

Following components installed in the system and  THEY ALL ARE IN ONE DOMAIN

1. Weblogic server 10.3.5 (wls1035_generic.jar)
2. WebCenter 11.1.1.5.0 (ofm_wc_generic_11.1.1.5.0_disk1_1of1.zip + p12348136_1035_Generic.zip )
3. WebTier 11.1.1.5.0 (ofm_webtier_linux_11.1.1.2.0_64_disk1_1of1.zip + webtier_p12395115_111150_Linux-x86-64.zip )
4. Access Manager WebGates 11.1.1.5.0 (ofm_webgates_generic_11.1.1.5.0_disk1_1of1.zip + Webgate_p12756804_111150_Linux-x86-64.zip)
5. Oracle Identity Management 11.1.1.5.0 (ofm_idm_linux_11.1.1.2.0_64_disk1_1of1.zip + p12395123_111150_Linux-x86-64.zip)
6. Oracle Identity and Access Management 11.1.1.5.0 (ofm_iam_generic_11.1.1.5.0_disk1_1of1.zip)
7. Oracle Entitlement Server 11.1.1.5.0 (ofm_oesclient_generic_11.1.1.5.0_disk1_1of1.zip + apm_p12917515_111150_Generic.zip + apm_p13328401_111150_Generic.zip)
8. SOA 11.1.1.5.0 (ofm_soa_generic_11.1.1.5.0_disk1_1of2.zip + ofm_soa_generic_11.1.1.5.0_disk1_2of2.zip)
9. ECM 11.1.1.5.0 (ofm_ecm_generic_11.1.1.5.0_disk1_1of2.zip + ofm_ecm_generic_11.1.1.5.0_disk1_2of2.zip


Following the below documentation:
http://docs.oracle.com/cd/E28280_01/doc.1111/e16793/patch_set_installer.htm#CHDCDBEJ

Performed the following steps :
1. Update WebLogicServer to 10.3.6 (p13529623_1036_Generic.zip) by following command:
JAVA_HOME=/oracle/java;export JAVA_HOME PATH=$JAVA_HOME/bin:$PATH; export PATH java -Djava.io.tmpdir=/WLS/temp -jar /WLS/patch/13529623/wls1036_upgrade_generic.jar

2. Install IDENTITY AND ACCESS MANAGEMENT 11G (Patch 16471723 ORACLE IDENTITY AND ACCESS MANAGEMENT 11G) using command:
/WLS/patch/16471723/Disk1/runInstaller

RESULT:

1. Binaries in /oracle_common/modules/oracle.jps_11.1.1/ were changed to correct version.
2. Binaries in /oracle/Middleware/Oracle_IAM/modules/oracle.jps_11.1.1/ WERE NOT(!) changed.
3. A restart of WLS throws error

JPS-06100: Policy Store version 11.1.1.7.0 and Oracle Platform Security Services Version 11.1.1.5.0 are not compatible

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms