OAAM 11gR2PS1 upgrade fails with UPGAST-00224: The specified database does not contain any schemas for upgrade Oracle Audit Services or the database user lacks privilege to view the schemas. (Doc ID 1592587.1)

Last updated on SEPTEMBER 14, 2016

Applies to:

Oracle Adaptive Access Manager - Version 11.1.2.1.1 and later
Information in this document applies to any platform.

Goal

We are upgrading OAAM 11.1.2 to 11.1.2.1 via latest Patch Set

We have completed the App Server installation and are now running the database upgrade with PSA.

OAAM selected in Components. (unchecked Partition Manager). 
The installer screen lists the database schemas, and they are disabled, so we cannot uncheck Oracle Audit Services (IAU Schema) which is not part of our installation.

Continuing on to the next screen displays the following message, and we cannot proceed with the upgrade:

UPGAST-00224: The specified database does not contain any schemas for upgrade Oracle Audit Services or the database user lacks privilege to view the schemas.
 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms