Directory-Server Denies Starting - libldap60.so (LDAPCSDK_5.10) => (version not found) not accessible (Doc ID 1594221.1)

Last updated on OCTOBER 11, 2016

Applies to:

Oracle Directory Server Enterprise Edition - Version 6.0 and later
Information in this document applies to any platform.

Goal

Problem description

This happens only in native package version of ODSEE software  both for solaris x86 and SPARC patches leading to this behavior

dsadm is no longer being able to start a DS instance after applying solaris 10 samba patch 119757-xx (where xx>=28) and is generating error message: 

 

A wrong library path to the native ldap libraries causes the issue if other 3rd party packages (like Samba) install their own libldap60.so library into the default OS library path. So wrong /usr/lib/64/libldap60.so is found first and used instead of correct /usr/lib/mps/64/libldap60.so.

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms