Errors When Installating the JAX-RPC Web Services Plugin for Netbeans (Doc ID 1602253.1)

Last updated on OCTOBER 25, 2016

Applies to:

NetBeans - Version 7.1 to 7.1 [Release 7.1]
Information in this document applies to any platform.

Symptoms

NetBeans 7.3

After installing the JAX-RPC Web Services module and restarting the NetBeans IDE, NetBeans throws many modules version dependency errors or module not found errors and although we disable those modules, we cannot manage plugins anymore.

To reproduce:

Install NetBeans 7.3 EE using a Java 7 JDK specifying Tomcat only and not Glassfish.
Create a new repository that points to :URL: http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz
Or
According to FAQ page
URL: http://wiki.netbeans.org/FaqPluginsInDevelopment
    To install the development update center

   Select Tools | Plugins from the menu and go to the Settings tab. Click Add. Enter the following:
   Name: NetBeans dev (or any name of your choice)
   URL: http://deadlock.netbeans.org/hudson/job/nbms-and-javadoc/lastStableBuild/artifact/nbbuild/nbms/updates.xml.gz

After restart you will see a lot of module dependency errors and version mismatches.

Warning - could not install some modules:
JSP Editor - The module Java Editor was requested in implementation version "9" but only "10" was found.
Bean Patterns - The module Java Editor was requested in implementation version "9" but only "10" was found.
Spring Web MVC - The module named org.netbeans.modules.spring.beans/0-1 was needed and not found.
18 further modules could not be installed due to the above problems.

After disabling modules, NetBeans will not let you manage plugins anymore. (uninstall and re-install required).

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms