My Oracle Support Banner

Agent raising "ODI-01219 Session preparation failure: database error while connecting to work repository" after an upgrade from ODI 10g to ODI 11g (Doc ID 1602493.1)

Last updated on JUNE 16, 2022

Applies to:

Oracle Data Integrator - Version 11.1.1.3.0 and later
Information in this document applies to any platform.

Symptoms

In ODI 11g, after an upgrade from ODI 10g, it is not possible to execute a Scenario from Studio using an Agent.
Following error is raised:


From the same server, the same Scenario runs fine while executing it with startscen.sh (or startscen.bat), meaning all the information in odiparams.sh (or odiparams.bat) are correct.

Changes

 Upgrade from ODI 10g to ODI 11g.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.