My Oracle Support Banner

Security: Missing Application-Library-Allowable-Codebase Manifest for /frmall.jar - Security Warning - Block Potentially Unsafe Components from Being Run? (Doc ID 1619833.1)

Last updated on JULY 24, 2018

Applies to:

Oracle Forms - Version 10.1.2.0.2 and later
Information in this document applies to any platform.

Symptoms

After upgrading to JRE 7 Update 51 the following warning is displayed in java console

security: Missing Application-Library-Allowable-Codebase manifest attribute for: http://hostname:port/forms/java/frmall.jar
security: Validate the certificate chain using CertPath API
security: Missing Application-Library-Allowable-Codebase manifest attribute for: http://hostname:port/forms/java/frmall.jar
security: Validate the certificate chain using CertPath API
security: Missing Application-Library-Allowable-Codebase manifest attribute for: http://hostname:port/forms/java/frmall.jar
security: Validate the certificate chain using CertPath API
security: Missing Application-Library-Allowable-Codebase manifest attribute for: http://hostname:port/forms/java/frmall.jar
.....................................................
.....................................................
security: Missing Application-Library-Allowable-Codebase manifest attribute for: http://hostname:port/forms/java/frmwebutil.jar

 

The first time Forms is run you will see the a dialog box similar to the following:

Figure 1

 

If you are using certain types of JavaScript calls in your Form, you will see a Security Warning Message similar to the following:

Figure 2

 

 

Changes

 Upgraded the JRE plug-in on the client to Java 7 Update 51 or newer.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.