Data Miner Requires Oracle Database Version 11.2 and Above (Doc ID 1623321.1)

Last updated on JULY 06, 2017

Applies to:

Oracle Data Mining - Version 12.1.0.1 and later
Oracle SQL Developer - Version 4.0 and later
Information in this document applies to any platform.

Symptoms

Oracle Data Miner is not working when 12c Personal Edition Database is used with SQL Developer 4.0.

Following error message is displayed when trying to establish a connection for ODM in SQL Developer 4.0:
"Data Miner requires Oracle Database version 11.2 and above".

But it works absolutely fine when "Oracle Data Miner Classic" Tool is used.
It also works fine when "12c Enterprise Edition" is used with "SQL Developer 4.0".

Changes

As per this link: "http://docs.oracle.com/cd/E16655_01/license.121/e17614/editions.htm#DBLIC111"

Personal Edition includes all of the components that are included with Enterprise Edition, as well as all of the options that are available with Enterprise Edition, with the exception of the Oracle Real Application Clusters option, which cannot be used with Personal Edition. Personal Edition is available on Windows and Linux platforms only. The Management Packs are not included in Personal Edition.

So, the component 'Advanced Analytics / Data Mining' is included in PE edition as well.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms