My Oracle Support Banner

マスターノート : WebLogic Server(WLS) パッチ、アップグレード・インストーラ・完全インストーラ (Doc ID 1666056.1)

Last updated on JULY 29, 2020

適用範囲:

Oracle WebLogic Server - バージョン 8.1 以降
この文書の内容はすべてのプラットフォームに適用されます。


詳細

この文書では、WebLogic Server (WLS) にパッチを提供する、WLS アップグレード・インストーラを入手・利用する方法、WLS 完全インストーラを入手・利用する方法を記載した文書へのリンクを記載しています。

アクション

パッチ

WLS にパッチを適用する最初のステップはパッチの入手です。すべての WebLogic Server のパッチは My Oracle Support で入手することができます。パッチ番号(Bug ID) や (以前使われていた) Smart
 Update patch ID を利用してパッチをダウンロードする方法の詳細な手順やスクリーンショットは How to Locate and Download Patches for WebLogic Server Using My Oracle Support <Note 1302053.1> で紹介しています。

2011年6月以前は、Smart Update Tool を利用してパッチをダウンロードできました。この変更については、WebLogic Net Installers and Downloading of Patches Via Smart Update Has Been Decommissioned (as of June 2011) <Note 1294294.1> で紹介しています。

パッチを入手した後、Smart Update Tool(Windows では bsu.cmd, UNIX では bsu.sh) を利用して、パッチを適用します。Smart Update はパッチ適用だけではなく、すでに適用されているパッチとの競合がないかどうかを確認する機能がありますので、Smart Update をご利用ください。

Smart Update ドキュメント

Smart Update のドキュメントはこちらにあります。Smart Update に関する重要で詳細な情報はこのドキュメントに記載されています。

Smart Update の利用

Smart Update を利用してパッチを適用する詳細な手順については、How to Apply WebLogic Server (WLS) Patches Using Smart Update <Note 876004.1> で紹介しています。

Smart Update は WLS バージョン 9.x とそれ以上のバージョンで動作します。もし、まだ WLS 8.1 もしくはそれ以前のバージョンを利用されている場合は、How to Apply Patches to a WLS 8.1 Environment <Note 942815.1> を参照してください。

Smart Update に関する詳細や問題については、Master Note on Troubleshooting Smart Update Issues <Note 1230725.1> を参照してください。

WLS 12.1.2 以降 : パッチ適用には OPatch を利用

WLS 12.1.2 以降では、 Smart Update は有効ではありません。これらのバージョンでは、パッチの適用に OPatch を利用します。詳細は、OPatch によるパッチ適用 を参照してください。

アップグレード インストーラ

すでに WLS がインストールされていて、より新しいバージョンへのアップグレードを行う場合は、アップグレードインストーラを利用することができます。どのようにアップグレードインストーラを見つけるか、またその利用方法については、以下を参照してください。:

完全インストーラ

メジャーリリースバージョンを変更する、あるいは、特定のアップグレード・インストーラがないというような、新規に WLS の完全インストールが必要な場合、完全インストーラが必要となります。完全インストーラの入手方法は以下を参照してください:

正しいインストーラの選択

OS やプラットフォーム (例えば、32bit か 64bit か)を考慮して正しいインストーラを選択することは難しい場合があります。Generic Installer はどのプラットフォームでも動作しますが、より便利なインストーラが存在する場合もあります。詳細な情報は以下を参照してください。:

 

本文書利用上のご注意
====================
本文書は英語で提供されている <Document 1075833.1> (最終更新日: 2017年7月15日) を翻訳したものです。
ご利用に際しては、英語の原文を併せてご参照頂くことをお勧めいたします。

コンタクト

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


本書の内容
詳細
アクション
 パッチ
 Smart Update ドキュメント
 Smart Update の利用
 WLS 12.1.2 以降 : パッチ適用には OPatch を利用
 アップグレード インストーラ
 完全インストーラ
 正しいインストーラの選択
コンタクト
参照情報

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.