JPS-06100: Policy Store version 11.1.1.7.0 Error Occurs During PS1 To PS2 Up-gradate Step to Start Admin Server (Doc ID 1680245.1)

Last updated on MARCH 08, 2017

Applies to:

Identity Manager - Version 11.1.2.2.0 and later
Information in this document applies to any platform.

Symptoms

Background:
Initially installed OIM 11gR2 base version and SOA 11.1.1.6.0 as brand new installation on 3 servers (srv1, srv2 and srv3).
After the installation and configuration was complete, our servers had following weblogic instances,

srv1 - AdminServer, oim_server1, soa_server1
srv2 - oim_server2, soa_server2
srv3 - oim_server3, soa_server3
oim_cluster -> oim_server1, oim_server2, oim_server3
soa_cluster -> soa_server1, soa_server2, soa_server3


It was later decided to have one dedicated Linux Machine for Admin Server, so deleted the instance oim_server1 and soa_server1 from the WebLogic Admin Console by navigating to oim_domain -> Environment -> Servers.
After deleting the oim_server1 and soa_server1, our server and instance mapping was like,

srv1 - AdminServer
srv2 - oim_server2, soa_server2
srv3 - oim_server3, soa_server3
oim_cluster -> oim_server2, oim_server3
soa_cluster -> soa_server2, soa_server3


Whenever patches were applied for OIM / SOA, the were only applied to srv2 and srv3.
Therefore, the Admin Server srv1 was always in base version.
This was the same logic for the PS1 upgrade for OIM11gR2.

Now as part of OIM11gR2PS2 upgrade, did same steps of only upgrading the SOA and OIM home binaries only in srv2 and srv3.
The SOA home, OIM home and Common home in server srv1 was still in older version (11.1.1.6.0 & 11.1.2.0.0).

Upgrading the environment from OIM11gR2PS1 to PS2 by following oracle document
(Oracle® Fusion Middleware Upgrade Guide for Oracle Identity and Access Management 11g Release 2 (11.1.2.2.0))
http://docs.oracle.com/cd/E40329_01/doc.1112/e48646/toc.htm

and completed the below steps
a) All Pre-Requisite
b) Set JVM Properties
c) SOA Upgrade along with Post upgrade activities
d) Upgrade Oracle Identity Manager Binaries to 11.1.2.2.0
e) Upgrade Database schemas (OIM schema, MDS schema, ORASDPM schema, SOAINFRA schemas, OPSS schema)
f) Upgrade Oracle Platform Security Services (OPSS)
g) Upgrading Java Required Files (JRF)
Next step is to upgrade Oracle Identity Manager Middle Tier.

Before upgrading OIM Middle tier, one needs to start Admin Server on srv1 and it throws following exception when the server gets started

Error message: JPS-06100: Policy Store version 11.1.1.7.0 and Oracle Platform Security Services Version 11.1.1.6.0 are not compatible.
weblogic.security.SecurityInitializationException: The loading of OPSS java security policy provider failed due to exception, see the exception stack trace or the server log file for root cause. If still see no obvious cause, enable the debug flag -Djava.security.debug=jpspolicy to get more information. Error message: JPS-06100: Policy Store version 11.1.1.7.0 and Oracle Platform Security Services Version 11.1.1.6.0 are not compatible.
  at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.loadOPSSPolicy(CommonSecurityServiceManagerDelegateImpl.java:1402)
  at weblogic.security.service.CommonSecurityServiceManagerDelegateImpl.initialize(CommonSecurityServiceManagerDelegateImpl.java:1022)



Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms