OAM-OIM 11g Integration: First Time User Login Fails (Doc ID 1934440.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle Access Manager - Version 11.1.1.5.0 and later
Information in this document applies to any platform.

Symptoms

Oracle Access Manager 11g has been integrated with Oracle Identity Manager 11g.

OIM and OAM are accessed via the same [load-balanced] Oracle HTTP Server (OHS) that is serving application requests. There is a WebGate installed on the webserver(s).
mod_wl_ohs has been configured on the OHS to route application, /oam and /identity requests to the different back end WebLogic Servers.
The idea is that the protected application, OAM and OIM pages will all be accessed using the same, single hostname.domain.

Users that existed in the LDAP Server before the OAM-OIM integration and users created new directly in the LDAP Server can login to the protected application using OAM SSO successfully.

However new users created in OIM Console are unable to login to the application using OAM SSO.

After submitting new user credentials in the OAM SSO login page any of the following occurs:
a) The login page is re-displayed.
b) The browser goes into a redirect loop.
c) System Error occurs.


Steps to reproduce

1. Login to OIM Console as xelsysadm and create a new user.
2. Close the browser.
3. Open a new browser session and access the WebGate protected application: the OAM SSO login page is displayed.
4. Submit new user credentials: the application page is not displayed as expected. Any of the above 3 issues occurs.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms