My Oracle Support Banner

Patching a GlassFish Server Installation that has been Previously Updated Using a Closed Repository Patch Fails with the Error "UpdateLogException: Package V pkg javadb-common 10.8.1.2,5.10:20111107T225929Z is already in the catalog" (Doc ID 1934498.1)

Last updated on OCTOBER 24, 2018

Applies to:

Oracle GlassFish Server - Version 3.1.2 and later
Information in this document applies to any platform.

Symptoms

You have an installation of GlassFish Server 3.1.2.x that has been previously updated using the Closed Repository mechanism.  A new patch has been released and the internal closed repository server, pkg.depotd, has been restarted referring to the new closed repository image. As part of this, the GlassFish Server installation needs to refresh it's view of the repository and when the pkg refresh command is run the following error is reported:

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.