Security Settings Lost On Portal Page After Changing Page ID

(Doc ID 1949568.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle WebCenter Portal - Version 11.1.1.8.4 and later
Information in this document applies to any platform.

Symptoms

A Portal page in 11.1.1.8.4 does not follow the security settings defined after changing the page ID and using the direct URL to access it.


The testcase is that there are 3 pages in a Portal
Home  PUBLIC access
-> SubPage1 autenticated-user access
->->SubPage11 Inherit

Using the pretty URL when not logged in :-
    http://<myhost:port>/webcenter/portal/JennyTest/Home/SubPage1/SubPage11   gives Page not Found as expected
and using the direct access to a page using
    http://<myhost:port>/webcenter/faces/oracle/webcenter/page/scopedMD/s4847cc5e_f3fc_43f0_a7f5_154636379f3c/Page6.jspx gives the Login page as expected



BUT after changing the ID of the page by going to
ADMINISTRATION - Portals - YourPortal - Pages - Choose SubPage11 - Advanced - change the ID by adding 1 character.

Using the pretty URL when not logged in :-
http://<myhost:port>/webcenter/portal/JennyTest/Home/SubPage1/SubPage11   gives Page not Found as expected
BUT using the direct access to a page using  http://<myhost:port>/webcenter/faces/oracle/webcenter/page/scopedMD/s4847cc5e_f3fc_43f0_a7f5_154636379f3c/Page6.jspx shows the page even when not logged in

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms