Error While Creating Domain During OIM Installation

(Doc ID 1959010.1)

Last updated on AUGUST 07, 2016

Applies to:

Identity Manager - Version 11.1.2.2.0 and later
Information in this document applies to any platform.

Goal

During installation of OIM, while creating of domain, getting the following error:

----------------------------
Reason: null

Exception:

Traceback (innermost last):
  File "", line 477, in ?
  File "", line 151, in copyEMClusterMBeanFiles
  File "E:\oracle\Middleware\wlserver_10.3\common\wlst\modules\jython-modules.jar\Lib/javaos$py.class", line 334, in system
  File "E:\oracle\Middleware\wlserver_10.3\common\wlst\modules\jython-modules.jar\Lib/popen2.py", line 235, in system
  File "E:\oracle\Middleware\wlserver_10.3\common\wlst\modules\jython-modules.jar\Lib/popen2.py", line 72, in __init__
  File "E:\oracle\Middleware\wlserver_10.3\common\wlst\modules\jython-modules.jar\Lib/javashell.py", line 64, in execute
OSError: (0, 'Failed to execute command ([\'sh\', \'-c\', \'mkdir E:\\\\oracle\\\\config\\\\domains\\\\IDMDomain\\\\config\\\\fmwconfig\\\\mbeans\\\\oim\']): java.io.IOException: Cannot run program "sh": CreateProcess error=2, The system cannot find the file specified')
-----------------------------------
Here are environment details:

OIM 11.1.2.2 ie. 11g R2 PS2
Weblogic 10.3.6
OS Windows Server 2012 R2
It is a HA environment.

Here are the document which were followed:

https://docs.oracle.com/cd/E40329_01/doc.1112/e28391/iam.htm#CACJFJCF
https://docs.oracle.com/cd/E40329_01/install.1112/e49521/oim.htm#INOAM98479
 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms