WebLogic Server Throws Security Errors After Upgrading Java SE (Doc ID 1980074.1)

Last updated on JANUARY 21, 2017

Applies to:

Java SE JDK and JRE - Version 1.5.0 and later
Oracle WebLogic Server - Version 10.0 and later
Information in this document applies to any platform.

Symptoms

When using security features in WebLogic Server (WLS) for itself or its applications, a variety of errors can be seen. These errors typically result in applications failing to run or even the WLS instance failing to start. Examples of the sort of errors thrown include: “javax.net.ssl.SSLHandshakeException: Invalid Padding Length” and “sun.security.pkcs11.ConfigurationException: Unknown keyword 'useEcX963Encoding'“.

Changes

A recent upgrade to a newer revision of Java SE.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms