My Oracle Support Banner

OPSS - Upgrading OSB 11g to 12c the Reconfiguration Fails: Domain Reconfiguration Failed! Failure: JPS-06173: Policystore upgrade from 11.1.1.4.0 to 12.1.3.0.0 not supported (Doc ID 1990534.1)

Last updated on OCTOBER 11, 2019

Applies to:

Oracle Platform Security for Java - Version 11.1.1.4.0 to 11.1.1.5.0 [Release Oracle11g]
Information in this document applies to any platform.

Symptoms

Upgrading application (Oracle Service Bus, without SOA) from 11g to 12c using the documentation.

Completed the pre-upgrade tasks and now it is failing at the next step which is to reconfigure the 11g WebLogic domain by using the reconfiguration wizard, as described here.

Getting an error in the reconfig.log regarding Policystore upgrade from 11.1.1.4.0 to 12.1.3.0.0 not supported.

Executed the upgrade assistant successfully to upgrade all the 11g schema to the version 12.1.3.0.0, but unable to identify the cause of the version being reflected as 11.1.1.4:

...<snip>...
2015-03-10 15:05:14,679 FINE  [86] com.oracle.cie.domain.SecurityConfigurationFactoryRunner - The OPSS Security Configuration Abort Process Started...
2015-03-10 15:05:14,679 FINE  [86] com.oracle.cie.domain.SecurityConfigurationFactoryRunner - The OPSS Security Configuration Abort Process Ended...
2015-03-10 15:05:14,679 SEVERE [86] com.oracle.cie.domain.TemplateImporter - Domain Reconfiguration Failed!

Domain Location:  MW_HOME\user_projects\domains\LocalDomain

Reason: oracle.security.opss.tools.lifecycle.LifecycleException: oracle.security.jps.JpsException: JPS-06173: Policystore upgrade from 11.1.1.4.0 to 12.1.3.0.0 not supported
oracle.security.jps.JpsException: JPS-06173: Policystore upgrade from 11.1.1.4.0 to 12.1.3.0.0 not supported
at oracle.security.jps.upgrade.tools.DBPolicyStoreUpgrade.upgradeDITAndData(DBPolicyStoreUpgrade.java:224)
at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeOPSSDITAndData(Upgrade.java:858)
at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeOPSS(Upgrade.java:650)
at oracle.security.opss.tools.lifecycle.OpssDomainConfigImpl.reconfigSubsystem(OpssDomainConfigImpl.java:274)
at oracle.security.opss.tools.lifecycle.OpssDomainConfigImpl.initializeSubsystem(OpssDomainConfigImpl.java:202)
at oracle.security.opss.tools.lifecycle.cie.OpssSecurityConfiguration.initializeSubsystem(OpssSecurityConfiguration.java:138)
at com.oracle.cie.domain.TemplateImporter.run(TemplateImporter.java:320)
at com.oracle.cie.domain.ReconfigurationGenerator.run(ReconfigurationGenerator.java:119)
at java.lang.Thread.run(Thread.java:745)

oracle.security.jps.JpsException: JPS-06173: Policystore upgrade from 11.1.1.4.0 to 12.1.3.0.0 not supported
oracle.security.jps.JpsException: JPS-06173: Policystore upgrade from 11.1.1.4.0 to 12.1.3.0.0 not supported
at oracle.security.jps.upgrade.tools.DBPolicyStoreUpgrade.upgradeDITAndData(DBPolicyStoreUpgrade.java:224)
at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeOPSSDITAndData(Upgrade.java:858)
at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeOPSS(Upgrade.java:650)
at oracle.security.opss.tools.lifecycle.OpssDomainConfigImpl.reconfigSubsystem(OpssDomainConfigImpl.java:274)
at oracle.security.opss.tools.lifecycle.OpssDomainConfigImpl.initializeSubsystem(OpssDomainConfigImpl.java:202)
at oracle.security.opss.tools.lifecycle.cie.OpssSecurityConfiguration.initializeSubsystem(OpssSecurityConfiguration.java:138)
at com.oracle.cie.domain.TemplateImporter.run(TemplateImporter.java:320)
at com.oracle.cie.domain.ReconfigurationGenerator.run(ReconfigurationGenerator.java:119)
at java.lang.Thread.run(Thread.java:745)

at oracle.security.jps.upgrade.tools.utility.Upgrade.covertExceptionWithStackTrace(Upgrade.java:1041)
at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeOPSSDITAndData(Upgrade.java:892)
at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeOPSS(Upgrade.java:650)
at oracle.security.opss.tools.lifecycle.OpssDomainConfigImpl.reconfigSubsystem(OpssDomainConfigImpl.java:274)
at oracle.security.opss.tools.lifecycle.OpssDomainConfigImpl.initializeSubsystem(OpssDomainConfigImpl.java:202)
at oracle.security.opss.tools.lifecycle.cie.OpssSecurityConfiguration.initializeSubsystem(OpssSecurityConfiguration.java:138)
at com.oracle.cie.domain.TemplateImporter.run(TemplateImporter.java:320)
at com.oracle.cie.domain.ReconfigurationGenerator.run(ReconfigurationGenerator.java:119)
at java.lang.Thread.run(Thread.java:745)
Caused by: oracle.security.jps.JpsException: JPS-06173: Policystore upgrade from 11.1.1.4.0 to 12.1.3.0.0 not supported
at oracle.security.jps.upgrade.tools.DBPolicyStoreUpgrade.upgradeDITAndData(DBPolicyStoreUpgrade.java:224)
at oracle.security.jps.upgrade.tools.utility.Upgrade.upgradeOPSSDITAndData(Upgrade.java:858)
... 7 more

...<snip>...



Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.