Label Issue When Fulfillment User Open The Disconnected Request (Doc ID 1997079.1)

Last updated on OCTOBER 04, 2016

Applies to:

Identity Manager - Version 11.1.2.2.1 and later
Information in this document applies to any platform.

Symptoms

Scenario: Have a disconnected application in which have added some additional attributes in parent form, and also attached a child form. There are 3 different Application Instances which are part of the same disconnected resource, and all are using the same UI form. Now, have updated the EL expression corresponding to 'label' and 'visibility' of those custom attributes using UI customization as wanted to show the label corresponding to the application. For eg: Using something like this for label:

#{pageFlowScope.requestFormContext.requestEntitySubType == "2242" ? "Label11" : (pageFlowScope.requestFormContext.requestEntitySubType == "2243" ? "LabelInst11" : (pageFlowScope.requestFormContext.requestEntitySubType == "2244" ? "LabelInst12" : "NoLabel"))}

and something like this for visible:
#{pageFlowScope.requestFormContext.requestEntitySubType == "2242" ? true : (pageFlowScope.requestFormContext.requestEntitySubType == "2243" ? true : (pageFlowScope.requestFormContext.requestEntitySubType == "2244" ? true : false))}

And one can see the correct labels during provisioning/under account tab of user/ even in request details. But when the fulfillment user open the disconnected request from the inbox, it still shows the default old labels and all the fields are visible.

How to resolve this?

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms