WSM Server Throws Null Pointer Error After Upgrading To WLS/SOA 12c (Doc ID 2003658.1)

Last updated on SEPTEMBER 20, 2016

Applies to:

Oracle Web Services Manager - Version 12.1.3.0.0 and later
Information in this document applies to any platform.

Symptoms

PROBLEM DESCRIPTION
----------------------------------------

After upgrading from SOA 11.1.1.7 to SOA 12.1.3.0, the WSM Server throws NullPointerException error.

The upgrade procedure was successful with no errors; Starting the Admin Server was also successful; however, when starting the WSM Server, which started fine and comes to running mode, the log file shows this error:


WHAT IS WORKING
--------------------------------

The servers started in running mode but the log shows the NullPointerException.

ENVIRONMENT
--------------------------
SOA 12.1.3.0
OS: Linux x86-64
OWSM

STEPS
------------
1. Upgrade from 11.1.1.7
2. Start the AdminServer
3. Start the wsm_server
4. Verify the diagnostic log file

BUSINESS IMPACT
--------------------------------
The NullPointerException generated in the diagnostic log file is causing some concern even though the wsm_server shows its status to be in running mode. The exception means that there is something wrong in the wsm repository which should be fixed. This may cause problems later when a production application using the owsm policies is deployed to this environment.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms