OPSS WLST Script Compatibility: Are Older Scripts (grantApprole.py, createAppRole.py, revokeAppRole.py) from WebLogic 10.3.5 Version Supported Against WLS 10.3.6? (Doc ID 2007450.1)

Last updated on MAY 12, 2015

Applies to:

Oracle Platform Security for Java - Version All and later
Information in this document applies to any platform.

Goal

Using both WebLogic 10.3.5 and 10.3.6 instances in the environment.

Some of the OPSS WLST scripts (grantApprole.py, createAppRole.py, revokeAppRole.py) were run from a 10.3.5 instance while connected to a 10.3.6 instance. Meaning, the roles in the 10.3.6 instance were modified as a result of running the scripts.

Everything appears to be ok but what is the compatibility is of these Oracle-provided WLST scripts between different WebLogic releases? Is this a supported configuration?

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms