My Oracle Support Banner

Java.lang.NullPointerException Seen After Deploying Application in 11.1.1.6.0 Cluster (Doc ID 2012772.1)

Last updated on FEBRUARY 20, 2019

Applies to:

Oracle WebCenter Portal - Version 11.1.1.6.0 to 11.1.1.6.6 [Release 11g]
Information in this document applies to any platform.

Symptoms

After re-deploying a new version of a WebCenter Portal 11.1.1.6.0 application in a cluster:

####<Mar 17, 2015 7:36:40 PM AST> <Info> <J2EE Deployment SPI> <HOSTNAME> <AdminServer> <Thread-208> <USER> <> <GUID> <1426610200119> <BEA-260121> <Initiating deploy operation for application, <APPLICATION_NAME>#V4.1.3 [archive: <MIDDLEWARE_HOME>/user_projects/domains/<DOMAIN_NAME>/sysman/upload/deploy/<APPLICATION_NAME>_V4.1.4/archive/<APPLICATION_NAME>-V4-1-4.ear], to Cluster_1 .>

####<Mar 17, 2015 7:36:40 PM AST> <Info> <Deployer> <HOSTNAME> <AdminServer> <Thread-208> <USER> <> <GUID> <1426610200301> <BEA-149038> <Initiating Task for <APPLICATION_NAME> [Version=V4.1.4] : [Deployer:149026]deploy application <APPLICATION_NAME>[Version=V4.1.4] on Cluster_1.>


Errors are seen in the login page using the new version on one managed server and the following NullPointerException is noticed in the logs:

java.lang.NullPointerException
  at org.apache.myfaces.trinidadinternal.renderkit.core.xhtml.FormRenderer.getAutoComplete(FormRenderer.java:1152)
  at org.apache.myfaces.trinidadinternal.renderkit.core.xhtml.FormRenderer.encodeBegin(FormRenderer.java:237)
  at org.apache.myfaces.trinidad.render.CoreRenderer.encodeBegin(CoreRenderer.java:317)
  at org.apache.myfaces.trinidad.component.UIXComponentBase.encodeBegin(UIXComponentBase.java:734)
  at javax.faces.component.UIComponent.encodeAll(UIComponent.java:928)
  at org.apache.myfaces.trinidad.render.CoreRenderer.encodeChild(CoreRenderer.java:405)
  at org.apache.myfaces.trinidad.render.CoreRenderer.encodeAllChildren(CoreRenderer.java:421)

The above exception is not specific to managed server and happen randomly on all four managed server.

Restarting the managed server once or twice will fix the issue.

It was also noticed that these URLs are not accessible on the Managed server with the problem:

http://<HOSTNAME>:<PORT>/Context_root/adf/styles/cache/gsr77bfa25a_a294_4c64_97a2_51becbb72bc9-desktop-t3ce0x-en-ltr-webkit-cmp.css
http://<HOSTNAME>:<PORT>/Context_root/adf/jsLibs/Locale1_2_12_3_3.js
http://<HOSTNAME>:<PORT>/Context_root/adf/jsLibs/resources/LocaleElements_en1_2_12_3_3.js?loc=en
http://<HOSTNAME>:<PORT>/Context_root/adf/images/t.gif

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.