The "Java Update Needed" Dialog is Presented Despite Setting the 'deployment.expiration.check.enabled' Property (Doc ID 2020591.1)

Last updated on NOVEMBER 05, 2016

Applies to:

Java SE JDK and JRE - Version 6 to 8
Microsoft Windows (32-bit)

Symptoms

Java SE 8 Update 31 presented the 'Java Update Needed' dialog after the new Critical Patch Update became available.
This was unexpected because the following property was set:

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms