OGG OUI Installer Fails With Java Version Failure (Doc ID 2026807.1)

Last updated on JULY 17, 2017

Applies to:

Management Pack for Oracle GoldenGate - Version 12.1.2.0.0 and later
Information in this document applies to any platform.

Symptoms

When running the OUI installer, it is failing the java version check even though I have installed the correct version of java:

usr/bin/java1.7.0_07/bin <s0931> ./java -jar -Xmx1024m /nbcogg/goldengate/fmw_12.1.3.0.0_ogg.jar
Launcher log file is /var/tmp/OraInstall2015-07-01_10-58-59AM/launcher2015-07-01_10-58-59AM.log.
Extracting files.................................................................
Starting Oracle Universal Installer

Checking if CPU speed is above 300 MHz. Actual 2660 MHz Passed
Checking monitor: must be configured to display at least 256 colors. Actual 16777216 Passed
Checking swap space: must be greater than 512 MB. Actual 60463 MB Passed
Checking if this platform requires a 64-bit JVM. Actual 32 Failed <<<<
Checking temp space: must be greater than 300 MB. Actual 1239 MB Passed

Some system prerequisite checks failed.
You must fulfill these requirements before continuing with the installation.


/usr/bin/jre1.7.0_07/bin <s0931> java -version
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) Server VM (build 20.1-b02, mixed mode)
/usr/bin/jre1.7.0_07/bin <s0931> echo $JAVA_HOME

/usr/bin/jre1.7.0_07/bin <s0931> echo $PATH
/usr/bin:/bin:/usr/sfw/bin:/usr/local/bin:/usr/X11/bin:/usr/openwin/bin:/opt/EMCpower/bin:/etc/emc/bin:/etc:.:/nbcos093_oracle/11.2:/nbcos093_oracle/11.2/bin:/etc
/usr/bin/jre1.7.0_07/bin <s0931>

 



Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms