Java 1.7.0_85 or 1.8.0_51 Causes ClassNotFoundException Oracle.forms.engine.Main (Doc ID 2038738.1)

Last updated on MARCH 08, 2017

Applies to:

Oracle Forms - Version 11.1.2.2.0 and later
Information in this document applies to any platform.
Checked for relevance on 08-Jan-2016

Symptoms

Cannot access forms in SSL mode after upgrading JRE to the latest 1.7 (1.7.0.85) or 1.8 (1.8.0_51) update.

Getting the error "ClassNotFoundException oracle.forms.engine.Main".


The Java trace shows:

javax.net.ssl.SSLException: Server selected improper ciphersuite SSL_RSA_WITH_RC4_128_MD5

 

Changes

 Upgraded JRE 1.7 to the latest update (_85)

or

Upgraded JRE 1.8 to the latest update (_51)

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms