OAFrameworkProvider Portlets Do Not Work in Portal and Shows Error: The portlet could not be contacted (Doc ID 2046136.1)

Last updated on MARCH 08, 2017

Applies to:

Portal - Version 10.1.4.2 to 11.1.1.7.0 [Release 10gR2 to FMW11g]
Information in this document applies to any platform.

Symptoms

When attempting to access a portal page with EBIZ OAFrameworkProvider JPDK providers, the EBIZ portlet is not displayed  and shows the error

 Error: The portlet could not be contacted

The Portal diagnostic log file  shows:

 

[2015-08-18T07:56:44.053+10:00] [WLS_PORTAL] [ERROR] [] [oracle.portal.page] [tid: content-fetcher156] [userId: <anonymous>] [ecid: 0056aW6QhIW2zGuaw_icMG0000_L00000b,1:26259] [APP: portal] [URI: /portal/pls/portal/!PRODINT_PORTAL.wwpro_app_provider.do_object_signon] ContentFetcher Unexpected Exception Request Failed:java.lang.NullPointerException name=content-fetcher156 label=webPortlet url=https://myfnd.com.au/OA_HTML/providers/OAFrameworkProvider time=0ms timeout=65000ms process=Dispatching

[2015-08-18T07:56:44.053+10:00] [WLS_PORTAL] [ERROR] [] [oracle.portal.page] [tid: content-fetcher138] [userId: <anonymous>] [ecid: 0056aW6QhIW2zGuaw_icMG0000_L00000b,1:26241] [APP: portal] [URI: /portal/pls/portal/!PRODINT_PORTAL.wwpro_app_provider.do_object_signon] ContentFetcher Unexpected Exception Request Failed:java.lang.NullPointerException name=content-fetcher138 label=webPortlet url=https://myfnd.com.au/OA_HTML/providers/OAFrameworkProvider time=0ms timeout=65000ms process=Dispatching

 

Also, in the log.xml file on the 10.1.3 oacore (where the framework provider is running)  shows error for authentication failure

"Raising SOAP fault code: AuthenticationFailure "

 

Changes

 No changes to enviroment done

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms