CopyConfig Exits With "CLONE-42023 Error in retrieving the Oracle WSM datasource detail" (Doc ID 2056620.1)

Last updated on NOVEMBER 05, 2016

Applies to:

Oracle Fusion Middleware - Version 12.1.3.0.0 and later
Oracle Web Services Manager - Version 12.1.3.0.0 and later
Information in this document applies to any platform.

Symptoms

Fusion Middleware 12.1.3.

Cloning a domain with copyConfig.sh fails with the following error:

SEVERE : [PLUGIN][OWSM] - ERROR - Sep 2, 2015 3:39:26 PM - CLONE-42023  Error in retrieving the Oracle WSM datasource details.
SEVERE : [PLUGIN][OWSM] - CAUSE - Sep 2, 2015 3:39:26 PM - CLONE-42023  Oracle WSM datasource (i.e. mds-owsm) is not configured in domain.
SEVERE : [PLUGIN][OWSM] - ACTION - Sep 2, 2015 3:39:26 PM - CLONE-42023  Make sure Oracle WSM datasource (i.e. mds-owsm) is configured in domain. Check clone logs for more details.
SEVERE : Sep 2, 2015 3:39:26 PM - SEVERE - CLONE-20929  "copyConfig" operation failed for oracle.wsm.lifecycle.t2p.impl.CopyConfigImpl plugin. Check clone log and error files for more details.
SEVERE : Sep 2, 2015 3:39:26 PM - SEVERE - CLONE-20963  "copyConfig" operation of J2EE domain failed. Check clone log and error files for more details.
SEVERE : Sep 2, 2015 3:39:26 PM - ERROR - CLONE-20218   Cloning is not successful.

 

Changes

The problem shows up only if at least one multi data source is configured anywhere in the domain.

The problem can still show up if the mds-owsm data source itself is a generic data source, but any other data source in the domain is a multi data source.

  

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms