Javax.management.RuntimeMBeanException: Audit Store Re-association Not Supported. (Doc ID 2065747.1)

Last updated on OCTOBER 19, 2015

Applies to:

Oracle Platform Security for Java - Version 11.1.1.7.0 and later
Information in this document applies to any platform.

Goal

Upgrading to 12.1.3.0 SOA from 11.1.1.5.0 to 11.1.1.7.0 to 12.1.3.0, still find 11.1.1.7 version for DEV_IAU schema even after upgrade. Here is sample:


IAU Audit Service DEV IAU IAU DEV_IAU 11.1.1.7.0 VALID N 9/2/2015 2:04:10.458237 PM
IAU_APPEND Audit Service Append DEV IAU_APPEND IAU_APPEND DEV_IAU_APPEND 12.1.3.0.0 VALID N 9/8/2015 10:47:43.146032 AM
IAU_VIEWER Audit Service Viewer DEV IAU_VIEWER IAU_VIEWER DEV_IAU_VIEWER 12.1.3.0.0 VALID N 9/8/2015 10:47:52.233073 AM

It is need it to be sure to have version 12.1.0.3 version across all the schemas. So, it is need it a clarification on whether the 11.1.1.7 DEV_IAU be deleted and recreated using 12c RCU. Will the old schema (11.1.1.7) have any data that might be corrupted? The schema is still referred to in jps-config.xml.
 

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms